Quelles sont les principales différences entre Joomla! 2.5 et 3 ?

La principale différence est une interface administrateur complètement réorganisée qui évolue vers un design moderne avec une interface utilisateurs beaucoup plus simple et conviviale. A partir de Joomla! 3, Joomla est maintenant réactif (responsive) au périphérique. C'est-à-dire que Joomla! est compatible avec les portables tablettes ou smartphones et peut être utilisé sur n'importe quel périphérique moderne.

De plus, il y a des douzaines d'améliorations détaillées de tout le coeur de Joomla!. Les principales sont :

icon starUn nouvel installateur que vous noterez quand vous créerez une nouvelle installation de Joomla!.

icon starJoomla! 3 est packagé avec des petits cadeaux pour les développeurs d'extensions, comme le support de Bootstrap et de jQuery.

icon starJoomla! 3.1 ajoute les possibilités de tags.

Combien de temps est supporté chaque version ?

Chaque version majeure de Joomla! est supportée pendant 4 ans et comporte des mises à jour en un seul clic. Par exemple, la série 2.X (qui comprenait 1.6 et 1.7 du à des conflits de nommage) a une durée de support de 4 ans de janvier 2011 au 31 décembre 2014. Le passage de 1.6 à 1.7 était une mise à jour en un seul clic. 2.5 sera supportée jusqu'au 31 décembre 2014. Donc la série 2.x aura 4 ans de support et c'était dans l'ensemble une expérience d'évolution en douceur pour les utilisateurs et les développeurs d'extensions.

La série 3.x aura aussi 4 ans de support. Ceci en tenant compte bien sûr de toutes les versions STS icon external, 3.0, 3.1 puis 3.2 qui auront seulement 7 mois de support chacune suivies de la dernière version 3.5. La dernière version de la série 3.x sera Joomla! 3.5, une version LTS, prévue pour être publiée en mars 2014 avec un support jusque fin 2016. Toutes les versions Joomla! 3.x pourront être mises à jour en un seul clic et devraient être dans l'ensemble une transition en douceur pour les utilisateurs et les développeurs comme la série 2.x l'avait été.

Comme le nouveau cycle de publication de Joomla! rend la mise à jour d'une version majeure à une autre version majeure (ex: 2.x à 3.x) relativement simple (voir la suite de la FAQ pour plus d'information), les utilisateurs ont les avantages additionnels d'un support composé, où ils peuvent aller d'une version majeure à une autre en ayant un support continu et ininterrompu.

Je construis un tout nouveau site. Dois-je créer un site Joomla 2.5 ou un site 3.x ?

Pour la plupart des sites, la série Joomla! 3 est la série préférée et démarrer par elle évitera une mini-migration de Joomla! 2.5 plus tard. Démarrer avec la série Joomla! 3 pour un nouveau site vous permet de bénéficier d'un plus long support compatible (avec les mises à jour en un clic) qu'en démarrant avec 2.5 maintenant, parce que le support de 3.x finit en 2016.

Quans vous démarrez d'un nouveau site, veuillez vous y prendre à l'avance et vérifier que toutes les extensions (y compris les templates) que vous prévoyez d'utiliser sont compatibles Joomla! 3. Si ce n'est pas le cas, Joomla! 2.5 vous apporte une solution bien supportée pendant ce temps.

Les sites qui sont actuellement en Joomla! 2.5 sont encouragés à rester en 2.5 jusqu'à la publication de Joomla! 3.5, sauf si ils ont besoin de mettre à jour plus rapidement pour bénéficier des avantages des nouvelles fonctionnalités de Joomla! 3. Nous avons fourni une mise à jour en un clic de Joomla! 2.5 vers n'importe quelle version Joomla! 3 et vous n'avez qu'à vous assurer que toutes vos extensions sont compatibles avant la mise à jour. (Voir la FAQ "Comment trouver des extensions compatibles Joomla! 3.x ?" c-dessous pour plus d'information).

Si je crée un site Joomla! 3, pourrai-je installer des extensions ?

Oui, vous pourrez installer des extensions compatibles avec Joomla 3.x. Le répertoire des extensions de Joomla! (Joomla! Extension Directory ou JED icon external) a une icône de compatibilité compat joomla3x permettant de savoir quelles extensions sont compatibles avec Joomla! 3.x, cependant le meilleur endroit pour vérifier la compatibilité d'une extension est le site de son développeur.

Comment obtenir un template Joomla! 3.x ?

Certaines compagnies de templates vont proposer des templates Joomla! 3 soit dès maintenant soit peu de temps après sa publication, mais vous devez leur demander à chacune. Certaines ont déjà annoncé que leurs templates seront prêts lorsque Joomla! 3 sera publié, mais d'autre non. Il faut aussi noter que certains des templates Joomla! 2.5 pourront fonctionner avec Joomla! 3 sans problème ni modification à effectuer. Le mieux c'est de consulter le développeur du template.

Comment trouver des extensions compatibles Joomla! 3.x ?

Visitez le répertoire des extensions de Joomla! (Joomla! Extension Directory ou JEDicon external) qui a une icône de compatibilité compat joomla3x vous permettant de savoir quelles extensions sont compatibles Joomla! 3.x, cependant le meilleur endroit pour vérifier la compatibilité est le site du développeur de l'extension.

Mes extensions Joomla! 2.5 vont-elles fonctionner avec Joomla! 3.x ?

Les extensions qui ont été développées nativement pour Joomla! 2.5 devraient fonctionner sur Joomla! 3.x avec très peu de modifications s'il y en a. Les composants et les templates vont nécessiter le plus de travail, alors que les modules et les plug-ins devraient fonctionner sans problème (en supposant qu'ils n'utilisent pas des méthodes obsolètes). Les extensions qui suportent Joomla! 2.5 et 1.5 dans le même package ne devraient probablement pas fonctionner tout de suite, jusqu'à ce que le développeur les mette à jour pour être compatible avec Joomla! 3.

En résumé, cela dépend de l'extension. Le projet Joomla a rendu le processus relativement simple pour la plupart des extensions, cependant pour certaines extensions cela pourra prendre un certain travail. Pour en être certain, informez les développeurs que vous souhaitez utiliser leurs extensions et consultez leurs documentations.

Que se passe-t-il si je crée un site Joomla! 3.x mais que l'extension que je souhaite est pour un site 2.5 ?

Vous devez parler avec le développeur de l'extension pour voir s'il projette de publier cette extension pour Joomla! 3 dans le futur immédiat. Les développeurs doivent faire des modifications mais leur ampleur dépend de l'extension.

Dois-je mettre à jour de Joomla! 2.5 à 3.x ?

Dans la plupart des cas probablement non. Joomla! 2.5 sera supporté jusqu'au 31 décembre 2014 et vous pourrez mettre à jour directement vers Joomla! 3 quand il aura été testé et trié à fond par les autres utilisateurs. Vous pouvez même attendre jusqu'à Joomla! 3.5 qui sera publié dans un an et toujours avoir une mise à jour directe. Les seules raisons pour lesquelles vous devriez mettre à jour sont si vous avez besoin des fonctionnalités de Joomla! 3 ou si vous souhaitez être à la pointe de la technologie.

J'ai un site 2.5 et je vois que le gestionnaire de mise à jour me laisse mettre à jour vers 3.x. Dois-je le faire puisqu'il me le permet ?

Non tant que vous n'êtes pas sûr à 1000%. Par défaut, Joomla ne vous laissera pas mettre à jour vers 3.x tant que vous n'avez pas activé le paramètre dans la configuration des mises à jour de Joomla! (administration >> Composants >> Mise à jour de Joomla! >> Paramètres >> Serveur de mise à jour). Si pour une quelconque raison vous avez modifié ce paramètre et que vous voulez que le gestionnaire de mise à jour ne vous laisse plus faire la mise à jour, modifier le paramètre à Support à long terme (LTS). Après avoir fait cette modification, vous ne recevrez que les mises à jour pour Joomla! 2.5

Note : Vous ne devez par mettre à jour de Joomla! 2.5 à Joomla! 3.x à moins que vous ne soyez certain que toutes vos extensions aditionnellement installées (de développeurs tierce partie), en particulier les templates, sont prêtes pour Joomla! 3.x ou ont une version Joomla! 3.x et que vous pouvez les mettre à jour.

Quelle est la suite après Joomla 3.0 ?

Joomla! 3.2 sera publié aux environs du 6 novembre 2013. Ne soyez pas inquiets parce que la mise à jour se fera en un clic et sera rétrocompatible. Si vous êtes en Joomla! 3.0 vous devrez mettre à jour vers 3.2 en utilisant le gestionnaire de mise à jour en un clic. Si vous êtes toujours en Joomla! 2.5, vous pouvez continuer d'attendre jusqu'à Joomla! 3.5 et avoir toujours une mise à jour directe.

icon info  Joomla! 3.2 a été publié et est disponible au téléchargement ICI !

D'accord, je suis prêt et je veux mettre à jour. Comment faire cette mise à jour ?

  • En premier, regardez les critères système requis pour Joomla! 3.x et assurez vous que l'environnement de votre serveur est conforme à ces critères.
  • Deuxièmement, assurez vous que toutes vos extensions (en particulier vos templates) sont compatibles avec Joomla! 3.
  • Troisièmement, créez un site de test et testez la mise à jour sur le site de test.
  • Quatrièmement, consultez un développeur de confiance si vous n'êtes pas sûr à 100% sur tous les points.
  • Cinquièmement, faites une sauvegarde complète de votre site (fichiers et base de données).

Quand vous êtes prêt, aller au composant de gestion des mises à jour de Joomla!. Cliquez sur paramètres et modifiez la valeur à Support à court terme (STS). Vous serez notifié de la disponibilité de Joomla! 3.x. Cliquez sur le bouton pour l'installer. Effacez le cache de votre navigateur pour être sûr que vous voyez les dernières modifications. C'est fait !

Finalement, revérifiez et assurez vous que tout fonctionne correctement.

Note : Sur certains serveurs vous pouvez devoir utiliser des méthodes de mise à jour alternatives comme utiliser l'installateur d'extensions.

Mais si je suis en Joomla! 1.5. Est-ce que mon site va crasher ? Dois-je migrer vers 2.5 ou vers la version actuelle 3 ?

Le support de Joomla! 1.5 est officiellement terminé. Est-ce que cela signifie que votre site va s'arrêter de fonctionner ? Non, votre site va continuer de fonctiionner comme il l'a toujours fait. Cependant les développeurs de Joomla! ne vont plus publier de nouvelles versions pour Joomla! 1.5, vous n'aurez donc plus de corrections pour les bogues ou la sécurité. Pour ces raisons il est recommandé de migrer de 1.5.

La mise à jour de 2.5 vers n'importe quelle version de Joomla! 3 est relativement simple puisque Joomla! a rendu le processus facile pour les nouvelles versions. Malheureusement, migrer de 1.5 n'est pas une tâche triviale. Heureusement il existe deux bonnes extensions qui facilitent le processus : jUpgrade et SP Upgrade.

Vous avez le choix d'aller directement à Joomla! 3.0 or d'aller à 2.5 d'abord. SP Upgrade et jUpgrade ont tous les deux des versions prêtes pour les deux versions. Veuillez consulter leurs documentations sur comment migrer de Joomla! 1.5 à 3.0/2.5.

Migrez vers Joomla! 3.0 si toutes les extensions que vous prévoyez d'utiliser sont compatibles Joomla 3.0. (Voir la FAQ "Comment trouver des extensions compatibles 3.0 ?").

Migrez vers Joomla! 2.5 si vous voulez le plus stable que Joomla! a à offrir et/ou si vous prévoyez d'utiliser de nombreuses extensions.

OK dernière question. Où puis-je trouver plus d'information sur Joomla! 3 ?

Vous pouvez trouver plus d'information sur http://www.joomla.org/3/fricon external.

 

Nous espérons que vous aimerez Joomla! 3 autant que nous ! Merci d'avoir lu cette FAQ.

Ont collaboré à cette FAQ :

Gary Jay Brooks, Nick Savov, Elin Waring, Jon Neubauer, Guillermo Bravo

Ont revu cette FAQ :

Sully Sullivan, Michael Babker, Andrea Tarr, Mark Dexter, Brian Teeman

 

Navigation dans l'aide